Setting up Workstation (desktop) and VM wifi


#1

I assume that the default Workstation VM image is not intended to operate on a desktop.

My host has a eth0 and a wlan0 (usb). VirtualBox will only allow each of the adaptors to present as Wired Ethernet adaptors to the Guest VM.

This results in Ubuntu Workstation not seeing any wireless extensions on the wlan0 because VirtualBox is presenting it as a Wired Ethernet connection.

My desktop is connected to a wifi router, which I want in turn to connect to the RaspberryPi Ubuntu. I am sure I can make the network connection but just posting here in case others run into the same issue.

There are apparently ways to get an Ubuntu Guest to capture the USB wifi card and set up as a Wireless Adaptor but I’ll try the alternative first.


#2

For the VM, it is perfectly fine to pass in the wlan0 as an ethernet device. Just make sure that the adapter is in bridge mode in the virtualbox settings.

In order to change what wifi you are on, you will need to change the network on the host side, but you will still be able to ssh into the robot and run pifi add.

Rohan