Raspberry Pi image on Pi 3 A+?


#1

I’m trying to use the Ubiquity Pi image on a Pi 3 A+ – it freezes on the splash screen at first startup. Tested with 2 different SD cards and 2 different Pi 3 A+'s.

I have a 3 B+and it works fine on that. Would love support for the 3 A+ since it’s just as powerful as the B+ in a smaller package.


#2

The firmware files that we distribute might be too old to support the 3A+.

If you are willing to do some fiddling around you can try the following steps to test out support for the A+ (because we don’t have one here to test with).

Boot the image on a Pi 3B+
Install swap: sudo apt install dphys-swapfile
Install deb building packages: sudo apt install devscripts dpkg-dev

mkdir rpi-firmware
cd rpi-firmware
dget http://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-firmware/raspberrypi-firmware_1.20190215-1.dsc
dpkg-source -x raspberrypi-firmware_1.20190215-1.dsc
cd raspberrypi-firmware # Check to make sure that this is correct
dpkg-buildpackage -rfakeroot -b

# Install
dkpg -i ../*.deb

Then reboot the 3B+, to make sure that it still boots, then put the SD card in a 3A+ and it should work.

If that works, then this will be a part of the next image allowing it to work out of the box on a 3A+.


#3

Hi Rohbotics,

Thanks so much for responding! I actually meant the Pi 3 A+, not the Pi A+. The Pi 3 A+ has the same processor as the Pi 3 B+.


#4

Sorry, yes I meant the 3A+. It has the same processor but reports a different board ID that the firmware that comes with the image doesn’t support. The above steps will upgrade your firmware to a version after the 3A+ came out, which should make it boot up and work.


#5

It worked! A couple of fixes below:

sudo apt-get update
sudo apt install dphys-swapfile
sudo apt install devscripts dpkg-dev quilt debhelper
mkdir rpi-firmware
cd rpi-firmware
dget http://archive.raspberrypi.org/debian/pool/main/r/raspberrypi-firmware/raspberrypi-firmware_1.20190215-1.dsc
dpkg-source -x raspberrypi-firmware_1.20190215-1.dsc
cd raspberrypi-firmware-1.20190215
dpkg-buildpackage -rfakeroot -b

# Install
sudo dkpg -i ../*.deb

There were also some GPG warnings about signatures along the way. I ignored them for now but FYI.

Thanks! I might also suggest for anyone else reading this that is trying to use it on an A+ that you disable X since it has half the RAM of the B+. I use all my Pis headless anyway but just worth noting that X is mostly unusable on the A+. If you really have to, consider FluxBox or some other lighter WM.


#6

Great to hear it works, the GPG errors can be ignored they are saying that you haven’t added the Raspberry Pi developers to your trusted keyring yet.

I’ll try to include the new packages on the next image, thanks for your help.