Raspberry pi 4 wont turn on hotspot when connected to ubiquity

Hello, I was using a pi3 on ubiquity and it worked fine, but we’re trying to upgrade it to a pi4 as we need more processing power. We used the exact same sd card with the latest kinectic image, we tested the pi4 headless and connected to a monitor and it worked fine but, when we connected it to the ubiquity, it didn’t turn on the hotspot. We tested it again with the pi3 and it created the hotspot without any problems. Any idea of what problem are we having?

Please tell us the revision of the MCB board. We can only support Pi4 on more recent MCB boards like the rev 5.2 because we added a 3.3V supply and have more recently bumped the voltage for Pi4 support to be 5.1V. So here are things for you to check and report back to here:

  1. Is the MCB rev 5.2 as seen on white silkscreen on left of board?

  2. Is the 5V ‘MAIN’ voltage on the top white ‘MAIN’ jack (left one) over 5V? Some rev 5.2 board we retrofitted and if so on the right white label area it may say some cryptic black sharpie markings that are something like ‘MOD 5.1’ but to test the voltage you will know. There was a component change that is standard in the most recent MCB board run but before that only some boards with label in sharpie have proper mod for good Pi4 usage.

  3. Also tell us the full serial number of your MCB board so I can know if it was one that was recent and as such had proper 5.1V parts for that production run.

Get back to us on these points so we know what you have.

Yeah, we checked and we have two MCB boards, one is 5.0 and the one we are using is a 4.9. Definitely not recent. Thank you for you time tho.

Ok so yes, both those board predate Pi4 updates. The Pi4 is not happy with 4.95 volts

So here is the mod for 5.1V part of it which may help your wifi. The 3.3V onboard MCB regulator is important for usage of OLED display so don’t put an OLED display on your 5.0 board which we did not ship with it anyway at that point.

I attach the doc we used to do the mods to allow 5.1V supply. Pay attention to removal of the big Zeniers which we renammed so the designators for your 5.0 and 4.9 boards are D303_5M and D303_5A.

The most important mod is to change value as per this doc for backside R314_5M which in the doc used current part number R1314 but both your boards have old non-standard numbers for parts with underscores and letters. Your R314_5M needs to be as the doc will say a 1.15k 1% resistor.
Since I cannot upload the doc they part numbers can be either of these 2 Yageo RC0603FR-071K15L or Stackpole RMCF0603FT1K15

I say this only if you have qualified surface mount repair skilz or can find someone to do it for you. I include resistor part numbers you could fine on digikey.com easily.

Crud! the forum will not let me attach anything but pictures. Contact me at mark@ubiquityrobotics.com and I can return an email.

1 Like

Hello Mark, thanks again for your reply. I sent a email to you but your address wasn’t found. Maybe a typo?

My mistake. perhaps best to send to support@ubiquityrobotics.com and in the subject put Attention Mark

1 Like

Email sent! Thanks for the help!

I have responded in detail in a reply email. Hope that helps. I think it will answer your issue with use of the older boards to power a raspberry Pi 4. Only rev 5.2 and later boards with proper 5.1V main power have been meant to properly power a raspberry Pi 4. Use of a raspberry Pi 4 on earlier boards is often a problem as we designed the main MCB board prior to raspberry Pi 4 release which has different power requirements.