Magni unable to move


I am struggling to get my Magni Silver to move. I have gone through the basic troubleshooting guide on the Ubiquity website, but it did not solve my problem. I am able to ping the robot and access the ssh terminal. However, when I try to control Magni using my keyboard by executing: “rosrun teleop_twist_keyboard”, Magni does not respond.

Any help would be greatly appreciated! Thanks.

It is possible that you’re running into the the firmware uart bug that’s in the process of getting fixed. It should be resolved if you reboot the robot, or you can try restarting the node by:

rosnode kill motor_node
roslaunch magni_bringup core.launch
1 Like

Please post here what is the first step number that fails on the verification tests. That will help us resolve this for you. Also I assume you have a very recent Magni and that your MCB board is version 5.2. Is that correct? This page will help identify MCB board if it is not 5.2 which has easily read rev on left of board.

Although I very much doubt this is the issue I realized that the verification page never explained the two power switches and what is required to have the robot fully powered up and ready to move. Also an important note was added just in case a switch board was shipped without a critical jumper required on newer switch boards.
So here is the link again:

After some troubleshooting, I found out that the issue was from my edits of the /etc/ubiquity/robot.yaml file when I was setting up the RaspiCam for upward-facing navigation. It works as per usual now. Thanks for all the help!

Glad you resolved your issue.