Magni RH motor sticking issue

Hello. I am facing some issue with Magni RH motor. Tried using both Android app as well as the teleops-twist-keyboard. Attached is the youtube link to the video showing the problem. Is this something to do with the motor driver calibration?

Thanks in advance.


Hello Omar,
This is acting like a wiring problem with the motor cable wires for that right side motor.

This looks like production problem or something came undone in shipment. Extremely odd but lets start using information below.


I have here how the wires are supposed to be connected on the back of the board for the right wheel. See if a wire came out or a color is wrong for any of these wires. Focus most on the thin wires as those are the wheel encoder wires. Notice besides this picture each wire color is shown on the PC board.

Try to see that the wires are stripped and go in the correct holes and the screws are tight that hold the wires.

Hi Mark, it is indeed wiring problem. I disconnected the 7-pins round connector the the RH motor and reconnect back, and the problem is solved! Thanks a lot for your help.


Ok that is great news. I will consider this now resolved. Enjoy the Magni! Mark

Another first. The picture I sent is right out of my detailed instructions to production so they had the very same picture you saw. That is why the bottom of the picture it talks about the black wire as well. It is a picture to get all wires on one side correct.

This is the very first time I have seen this from our factory. What is very odd is that we have a final checkout where they drive a certain pattern and there is no way it would have passed in the condition you found and fixed.

So I want to ask if any wire colors were wrong OR maybe a wire was not connecting properly so in shipment is somehow slipped or the screw was not tight. Did you notice any screws were not tight? I want to feedback good information to the factory for QA.

No problem if you don’t remember but it would help our process if you noticed something.

Mark, I check all the motor and encoder wires and the terminal screws, and they are all good. Probably the round connector for RH motor & encoder was not firmly plugged in.

By the way, does the OLED display supposed to show something like IP address etc? I notice it is always blank/nonfunctional. I2C scan show it is there at address 3C.


The up to date OLED display node is not on our images yet nor does it come across on an apt upgrade. To get what you are asking you have to clone oled_display_to catkin_ws/src and do catkin_make then to make it start automatically do what is pointed out on it’s github page.

Install from catkin_ws/src git clone

Read this github to install or run manually

I just made more changes to help it’s reliability but we may not be completely solid yet.
Let me know your experiences but in different forum entry please.

Thanks on OLED info. Will post new topics if there is any issue with the OLED display.