Magni move base, does it work properly?

Hi Ubiquityrobotics, All,

I’m trying to use move base (path planners) with Magni in a Gazebo enviroment,

first question is are the parameters tweaked to optimal? (below, say for global costmap, local costmap and common costmap, they seem to be different from default values inside and not sure how you came up with them…)

Reason I ask is when I launch the move base node with the parameters above, Magni does not move at all when I send a 2D nav Goal (and yes I had done localization already with AMCL and the laser seems correctly boucing off the walls…) but it wont just move at all, and errors below, Magni just stuck there,

I switched on recovery_behaviour_enabled: true in the move base and that didnt help either…,

Please assist

Tried both navfn and carrot planner and that didnt help as well…, got frustrated,

Okay, so i am not part of the magni people, but my guess would be that maybe you can adjust the cost value in the code.

If I understood correctly, it seems like that the cost value is not allowing the magni to make a decision on adjusting itself. So, give it a shot at adjusting the code ands see what happens? Or maybe spawn the magni somewhere else

It looks like it’s registering a potential collision there. If I recall right there’s some kind of bug in gazebo where the lidar would detect parts of the robot despite them not being in line of sight at all. Have you tried using laser filters with a box filter to remove scan points that hit the robot? That might do it.

1 Like

ok, that kind of make sense, when you mention the cost value, do you mean adjusting the cost scaling parameter below for the global cost map and local cost map?

Hi All, Ubiquity Robot,

Ok I got further since I haven’t got any replies to my previous question,

I loaded a few simple obstacles from Magni to navigate around ,

First set of planners I used are:

  1. base_global_planner > navfn/NavfnROS

  2. base_local_planner > dwa_local_planner/DWAPlannerROS

and it does avoid the obstacle and goes around it which is great but but… …when everytime i send a 2D nav goal to it …, it thinks for like 30 seconds before it can figure out a path to go … why is that please? and what parameter I need to adjust here? I’m lost now…,

Second set of planners I used (which is by defaults for the local planner) are:

  1. base_global_planner > navfn/NavfnROS
  2. base_local_planner > TrajectoryPlannerROS

It responded faster with this set of planners , however as you can see below, Magni just crashes to the obstacle , it tries to rotate recovery several times but fails…,

I would of thouht that TrajectoryPlannerROS would work better but it just hits the obstacle…,

I would appreciate if you can let me know what I’m doing wrong here…? or parameters I need to adjust etc…,

Hi All,

Can I please get a respond on this issue I’m having ??

Besides simulation on gazebo with Magni, I tried in real life today and done map_runner first in Magni_lidar and then roslaunch magni_nav move_base.launch (with nothing modified)…

And I keep getting these errors below ? please advice me on how to resolve this frustration…I couldnt use it at all…,