Magni does not move

I have s=been successful in connecting to Magni via ssh through the vm and using robot commander but Magni will not move.

What types of tests can i perform to diagnose the issue?

I would do is as follows.

  1. Make sure your battery is installed correctly, with all the contacts fully attached and the batteries are fully charged. A pair of fully charged Lead Acid batteries should give around 26-27V - if you don’t have a voltmeter the robot can self report battery voltage which is covered later on in this message (point 5). A good way to make sure the batteries are fully charged is by plugging in the provided charger. If it switches off automatically then the the batteries are fully charged.

  2. Make sure that both push buttons on the front of the robot are out all the way (one of the push buttons de-energizes the motor circuit as an emergency stop). Both blue and red LED on the PCB that has the switches should be illuminated.

  3. Check the 5 LED on the master control board (the big PCB on the robot) that you can see on the front of the robot right above the switch PCB. All 5 should be illuminated. The top one should blink briefly every 6 seconds. If you don’t see this behavior then email

  4. Check the fuses on the robot - you should be able to visually see if the fuse is blown.

  5. SSH in to the robot. Type

rostopic list

This will list all the available topics on the robot one of which will be /battery_state or similar then type

rostopic echo /battery_state

it will give you a bunch of diagnostic information about the battery state. Confirm that the battery voltage is at least above 25V. This is also a good way to confirm that you are getting correct communication between the raspberry pi main computer and the master control board.

  1. Before trying robot commander ssh in to the robot and on a command line running on the robot itself just try teleop by typing

rosrun teleop_twist_keyboard

once this is running you should be able to drive the robot forward by typing the “I” key.

If that works then the problem may be with robot commander, the connection between the cellphone and the robot or some other problem with your cellphone. Sometimes if an Android phone is connect to a data plan then the phone will try to direct packets from robot-commander to the internet rather than the robot. Personally I always switch off my external data plan on my android phone before trying to make robot commander work.

  1. The robot has 2 electronic circuit breakers (ECB) one for all the digital systems (computer micro-controller etc) and one for the main robot power. This is done so that if the motor ECB trips the computer can still log diagnostic data. The consequence of this is that the motor power ECB can trip and you still see plenty of illuminated LED etc. Depending on the reason why the motor ECB trips it can sometimes trip and not come back up until all the power in the circuit is gone (including all the capacitors). In this scenario, switch everything off, unplug the batteries and leave the robot overnight so the capacitors discharge. Plug the batteries back in and try steps 1-6 again.

If that doesn’t work then come back here and we’ll add diagnostic steps or email and we’ll take it from there.

once i turn on both buttons on the front magni was able to move. I now call the extra button on the front “the parking brake” button.