Local SSH doesn't work after connecting to my home network


#1

I downloaded the PI3 image, and all was well. I followed the instructions to change my password and host name, and all was well. Then I followed the instructions to connect to my home network and I could no longer SSH into that raspberry pi. I followed these steps:

ssh ubuntu@ubiquityrobot.local
passwd (then followed prompts to change password)
sudo pifi set-hostname NEWHOSTNAME
sudo reboot

—> OK so far, now they have me log it into my home network

ubuntu@NEWHOSTNAME:~$ pifi list seen
ubuntu@NEWHOSTNAME:~$ sudo pifi add MyNetwork password
sudo reboot

I know this works to connect because I used a monitor and can see that I am logged onto my home network. I can even ssh from this machine to another pi (just running raspbian) in my home. But if I try to ssh in or even ping, I get errors. if I use the host name (ssh ubuntu@ROS_PI.local) I get host not resolved. if I use the ssh ubuntu@IP_Address, I get connection refused. If I ping the IP, I get icmp open socket: operation not permitted. (ubuntu is the pre-loaded user name)

Is there some typical setting in linux that changes with host name or wifi config that would suddenly not allow ssh?


#2

Do you know for sure zeroconf networking is working properly on your router? If it isn’t then ROS_PI.local will not work - and you’ll have to get zeroconf networking running right on your router or you’ll have to log in using an IP address.


#3

After correcting an noticing a mistake I was making with the IP address, I can in fact SSH in that way. I am not familiar with zeroconf or how to verify, but it is very odd to me that I can ssh into two other machines running linux with just their host names (One raspberry pi and one acer netbook running raspbian/debian). I’ll dig deeper into zeroconf, but it’s less critical now that I can get in and have vnc working as well.