libEGL warning :DRI2 failed to authenticate while launching rviz

Hello everyone,

I’m launching rviz for opening my urdf

I’m getting the following error

libEGL warning : DRI2: failed to authenticate
i have tried this method https://raspberrypi.stackexchange.com/questions/61078/qt-applications-dont-work-due-to-libegl still not working

but still error persists
Thanking you

Does ’ rosrun rviz rviz ’ work?

While Rviz will run on a Pi, most people run it on a workstation.

LibEGL is more likely a display issue.

rosrun rviz rviz is not working ,
LibeGL how to solve that ? do you have any idea ?

Hey @msfarhan123456, can you please post the entire output of rviz when you try to launch it?

What image are you using for the Pi? That screenshot doesn’t look like our image, which uses LXDE.

Hey

i can launch rviz from rosrun rviz rviz it will open empty

but if i launch using my files like roslaunch slam display.launch with stl files in it
im getting error like this

and also im trying to achieve to load rviz in x11vnc for giving access to people who are in remote places .

a help will be apprecitated .
Thanking you
m s farhan