Keyserver failure

I’am trying to add ubiquity repo on a ubuntu 20.04 (non-ubiquity image) following the documentation: noetic_packages_repositories

but adding keyserver wont work:

Executing: /tmp/apt-key-gpghome.zBSETbPUSW/ --keyserver hkp:// --recv-key C3032ED8
gpg: keyserver receive failed: Server indicated a failure

Is it a problem on my side? Thanks in advance

Please type the exact thing you typed when you got this error.

On brief inspection just now, the webpage you refer to may be out of date because I see ‘focal’ in the command line. So knowing more on what you were typing is valuable here for this question.

Sometimes this changes so I’ll ask others what the line is these days then try to correct the web page. We normally have this setup on our own images already so this can hit persons using non ubiquity robotics images.

sorry for the lack of information,

I’am trying to add the ubiquity repo for an ubuntu 20.04, as I wanted to install pifi on my raspberry pi and installing it through source isn’t working (pifi doesn’t open AP nor connect to wifi).

Following the pifi repository I followed the link package_repositories so I could try and install it from the debs.

Running the commands as seen in the documentation:

sudo sh -c 'echo "deb focal main" > /etc/apt/sources.list.d/ubiquity-latest.list'

Works fine, but when I try to add the signing key to the trusted list, using the command:

sudo apt-key adv --keyserver hkp:// --recv-key C3032ED8

After a while, it returns the keyserver failure:
gpg: keyserver receive failed: Server indicated a failure

Ok thank you. So you said ‘focal’ in the command. I tried this simply using ‘noetic’ however I got the same error you saw.

I have passed this on to others who are more aware of the packages. No response yet.

I seem to remember something like this happening in the past but I did not make a note. My top suspect is the key has changed OR has expired. Thanks for your reporting this issue.

Thanks for the response. Can I ask you to let me know when it starts working again? Thanks in advance.

I’am having the same problem, did you get a response back?

I looked again at this but again, am not an apt guru. On our image there is one difference that may account for the issues. Note the URI ends in ubiquity-testing and so the command line would not have been right. The file I will show now is /etc/apt/sources.list.d/ubiquity-latest.sources

ubuntu@ubiquityrobot:~$ more /etc/apt/sources.list.d/ubiquity-latest.sources
Types: deb
Suites: focal
Components: main pi
Signed-By: /usr/share/keyrings/ubiquity-archive-keyring.gpg

So ‘maybe’ the line should be like this instead:
sudo sh -c ‘echo “deb focal main” > /etc/apt/sources.list.d/ubiquity-latest.list’

As far as the keyserver key if the one shown is not valid any longer I don’t know what the proper hex --recv-key value would be.

I don’t want to do this because my image works fine and maybe this test is best done on your end where you want the ubiquity-latest.sources to look like what I have above THEN try and cross fingers while doing the sudo apt-key line

Let us know if this works please.

When I do a ‘sudo apt update’ I get this and note the ubiquity-testing shows in this:

ubuntu@ubiquityrobot:~$ vie /etc/apt/sources.list
ubuntu@ubiquityrobot:~$ sudo apt update
[sudo] password for ubuntu:
Hit:1 focal InRelease
Hit:2 focal InRelease
Hit:3 focal InRelease
Hit:4 focal-updates InRelease
Hit:5 focal-security InRelease
Hit:6 focal-backports InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
331 packages can be upgraded. Run ‘apt list --upgradable’ to see them.

And more digging (again, im no expert but trying to help). Our images have this all setup so this is purely to try to help in this non-supported situation.

Refer to this page which is generic

Center of this page is third party repo support and it explains some things I have discussed like the images we have today have file /etc/apt/sources.list.d/ubiquity-latest.sources as I have pasted above and it references a ‘Signed-By’ line with a path to /usr/share/keyrings/ubiquity-archive-keyring.gpg

In your case that file will not be present so you need that file on your system in /usr/share/keyrings/ubiquity-archive-keyring.gpg and this is where I am stuck now. I have this file so will try to attach, this may be valuable to solve this issue you are having in not using our images where this is already setup.

ARRRRRGGGG! I cannot upload this file and cannot find an extension to trick the stupid upload rules. So to get this ‘darn’ (note the PC language used although in person it was more explicit.

So send me an email at and say in subject ATTENTION Mark and we do it that way. ARRRRGGGG!

Hey, I have the same failure… can you send me this too? my email