How do I disable WiFi access point?


#1

Hi,
I’m not very skilled with ubuntu’s configurations. i would like to disable the Wifi access point options preinstalled on your build and set up the WiFi for automatically connect to my home network but I don’t know how to do.
Thanks in advance for your help.
Diego


#2

We have written and installed a tool called pifi to do exactly that.

How to use it is described here:

The short version is that. You log in to the raspberry pi computer on your robot and

  1. Change the default log in password use the command

passwd

to do this

  1. You probably want to change the name of the computer on your robot using the following command

sudo pifi set-hostname NEWHOSTNAME

where NEWHOSTNAME is the name you want your computer to have on your home network.

  1. You then need to reboot the computer on your robot and use the following command:

sudo pifi add MYNETWORK PASSWORD

where MYNETWORK is the name of your home network and PASSWORD is the WiFi password of that network.

In general our tutorials have most of the information you need to do things like this with our image. Check them out here:


#3

we are trying to change WiFi network on our Magni robot and we used

“sudo pifi add myNETWORK PASSWORD”
and did a

" reboot"
The robot keeps on connecting to old network also pifi list seen does not output any information on the screen which is bit strange because of we have couple of AP’s aroound.


#5

The answer is:

  1. sudo pifi add ssid password;
  2. To remove bad you need to delete file in /etc/Networkmanager/system-connextions/ ap

#6

Did the above solution work for anyone? Every time I reboot the raspberry pi, it goes to the Access Point mode. I want to be able to disable that and let it connect to a different WiFi network always. How do I do that? I even tried deleting the AP mode from the list of known WiFi configurations, it still shows up again.


#7

What is the output of sudo systemctl status pifi?