Fiducial Follow


#1

I was able to test the fiducial follow and it works fine but i have a question about it!

When i operate the robot in “fiducial follow mode” there is a way to the robot avoid the obstacles? Because on my tests the robot just try to follow and didnt avoid the objects! Its that normal?

Thanks in advance!


#2

Yes the robot in fiducial follow will go wherever you tell it to go without regard for obstacle avoidance. This is the same with all the manual modes of operation.

If obstacle avoidance is something you want then it is relatively easy to implement. In source code you could for example subscribe to a sonar topic and stop when the distance to a detectable object drops below a certain level.

To see the fiducial follow source code take a look at.

Also take a look at the accompanying documentation.


#3

@davecrawley @rohbotics

i have installed the sonars and renamed the file from ubiquity_sonar to pi_sonar as described on the fix but the sonars seems to not be working! I´ve succesuflly run them and receive the message that the sonars are ready but the robot still dont avoid obstacles! let me attach a picture in order to you see if the error that appears mean something to you! thanks for all!!


#4

I’ve solved the issue by editing the robot.yaml file as described in the tutorial… Thanks


#5

@rohbotics @davecrawley
Now that i have the sonars working do you think that its possible to buy more to put on the back of the robot, kinda like LOKI? because sometimes te robots makes the movements moving backwards and that can be dangerous!

Another question! Where can i adjust the sonar radius of avoidance?

Thanks


#6

Could you clarify what you mean by ‘sonar radius of avoidance?’

Thanks


#7

The minimum range for the sonars in cm wich the robot should stop, by default it seems 3/4cm!

Im trying to make myself clear :slight_smile: sorry for my lack of knowledge on the right terms!


#8

move_basic will stop if an obstacle is detected in the distance that it moves in one second. If this is something that you want to adjust, we could make it configurable parameter in a future release.


#9

Thanks for your answer, i just think it needs to react quicker to stop the robot! Because sometimes the robot hits the wall in some ocasions even that is at low speed, because it detects too late! Maybe the sonar needs to be more sensitive to objects!


#10

can we get an update to the robot commander app to set magni into “follow” mode?


#11

Well its all open source - that’s the beauty of it. If you have an itch that you want to scratch take a look at the source code and make a pull request!

Just be aware that follow uses a fast low resolution camera mode while localization uses a slow high resolution one - so you’ll likely compromise performance of one or the other if you do this.

There is a work around to this that I can describe in more detail but needs some extra implementation steps.