Enable RPi3 WiFi device?


#1

Installed your RPi3 image (thanks!) and did a lot of other stuff with it using hardwired network before trying the WiFi. Now ready to use WiFi but don’t see your AP’s SSID.

When I do ‘pifi status’ (after reboot), it says:

Network Manager reports AP mode support on wlan0
Device is not activated.

Suggestions?
Have I deactivated WiFi somehow by using wired connection?
How do I reactivate it? (Please, not reloading the image?)

Support resources for the RPi all seem to assume Raspbian or other software, and don’t seem helpful for this instance.

FWIW:
‘ifconfig -a’ shows a wlan0 interface (b8:27:eb:10:28:17), but ‘ifconfig’ does not.

Thanks!
= = =
On further investigation, ‘sudo ifconfig wlan0 up’ responded with:

SIOCSIFFLAGS: Operation not possible due to RF-kill


#2

What is the output of nmcli dev wifi ?


#3

‘nmcli dev wifi’ responds with a single line (which appears to be column headings):

  • SSID MODE CHAN RATE SIGNAL BARS SECURITY

BTW: I unblocked wlan0 with rfkill, and then turned it UP with ifconfig. It now appears in ifconfig (with zero packets). But pifi still reports ‘Device is not activated’ And, for good measure, when I reboot, wlan0 is blocked again by rfkill.


#4

Never mind!!

Running ‘headless’ I couldn’t see it. Connecting to monitor I see the “Enable WiFi” control. Presto!

(How that’s happening under the covers… Who knows!!)

Sorry for wasting your time.


#5

Well there is important learning here for everyone who is screwing with network connectivity. If in doubt connect a monitor and keyboard. Its way easier to figure out network problems that way!