Displaying Compressed Images crashed after a while using raspicam


#1

hello everybody i’m using raspicam in raspberry , so in order to use compressed images in my laptop i run my subscriber node , my imshow run correctly but after a while the image freezed and blocked … with image raw the image streaming worked correctly but the fps was too low for that i did compile UbiquityRobotics/raspicam_node that has compressed image publisher but the image freeze after 1 minute…


#2

What do you mean by “my imshow”? Do you have your own subscriber node, or are you using rqt_image_view?


#3

both of them , the rqt_image_view and the my subscriber node with cv2.imshow()


#4

Ah, that is an interesting issue, have not seen it before.

A few more questions to help me better understand whats going on:

When it crashes, are you still able to ssh into the pi?
Does rostopic echo on the compressed image topic work on your laptop? What about locally on the Pi?
Are you using any GUI features of the pi?


#5

-the ssh still work
-rostopic shows nothings…
one thing i do is that Im using raspberry 3 B+ , and ubuntu mate , which i think does not support yet this rpi , but i created a publisher node in python code that publish compressed images it work properly but it take a huge ressource of cpu in raspi about 60% …


#6

Sounds like something in raspicam_node is crashing, probably the jpg encoder on the GPU.

Could you use our ubuntu image, as we keep the GPU drivers up to date (which the ubuntu mate team doesn’t seem to do) https://downloads.ubiquityrobotics.com/pi.html

Rohan


#7

Thank so much rohan i will try this , its not just the gpu encoder its bunch of things does not work , like raspiconfig , i2c , pwm ,building some library … i installed ubntu mate just because i needed ROS …


#8

hi rohan thank you for the last help , however i still facing the same issue the image freeze after 1 minute , i don’t know how to fix that ,


#9

Are you running over Wifi or Ethernet on the Pi? Have you tried using a lower resolution?


#10

i’m using wifi , yes even in low resolution still have the issue the window freeze and no error shows up, when i kill the process it give a msg about Assertion Failed , i thing it’s somthing related to the buffer is it ??


#11

Just to make sure, you are running ROS Kinetic on both the pi and the host, correct?

What is the assertion failed message?


#12

I’ve had the same issue when using raspicam_node on Turtlebot3. Turns out the latest version makes it freeze. Not sure why, but the older version works well.


#13

Hi,

This issue should be resolved now (https://github.com/UbiquityRobotics/raspicam_node/issues/65)

Let me know if this comes up again.

Thanks to everyone who provided information about the bug!

Rohan