Connecting to the Robot through SSH


#1

I am currently trying to connect to the robot through SSH following the instructions on the Learn page. However, after trying both methods, I am not able to get past the option of saying yes to a similar error message as this

“ The authenticity of host ‘10.42.0.1 (10.42.0.1)’ can’t be established.
ECDSA key fingerprint is SHA256:sDDeGZzL8FPY3kMmvhwjPC9wH+mGsAxJL/dNXpoYnsc.
Are you sure you want to continue connecting (yes/no)?”

I can enter in the password for the Ubuntu user, but without running the ssh as a sudo instruction, I am not able to get past this error as I am being instructed to “contact your system user” on the VM interface. I tried running this as a sudo command, but it seems that the root password is different than that of the Ubuntu password. Does anyone have any suggestions for getting past this whether it be the password for the root user or some other known solution?

I tried to SSH into the ubuntu@ubiquityrobot.local and the system said it didn’t recognize that name or service. Therefore, my current approach is SSH-ing into 10.42.0.1.

Thanks again!


#2

Can you send some screenshots of the error when you try to ssh?

You shouldn’t have to run ssh as sudo ever, even if logging into another computer’s root.

What is the output of ls -al ~/.ssh?

PS: Run sudo apt install avahi-daemon libnss-mdns in your VM, and make sure that your networking config is in ‘Bridge Mode’ to get .local addressing working.

Thanks
Rohan


#3

It seems that my network doesn’t allow .local (zero-config) so I had to find another way around, but I have been able to get in through SSH and also directly connecting to the Pi. Any suggestions for problems with Rviz? I can open another topic. I seem to be missing some of the Magni Files even though I’ve gone through all suggested updates and installed the ros-kinetic-magni-robot repo.

I’m specifically getting the error from Fixed Frame: “No tf data. Actual error: Fixed Frame [odom] (sometimes [map]) does not exist.”


#4

I get this weird error when trying to connect via ssh:

any thoughts on how to fix this?

ubuntu@ubuntu-VirtualBox:~$ ssh ubuntu@10.42.0.1
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
SHA256:erdeaAUcXgoriwuOA3wnsWQgTxFKxfv23pp1nHJmov4.
Please contact your system administrator.
Add correct host key in /home/ubuntu/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /home/ubuntu/.ssh/known_hosts:3
remove with:
ssh-keygen -f “/home/ubuntu/.ssh/known_hosts” -R 10.42.0.1
ECDSA host key for 10.42.0.1 has changed and you have requested strict checking.
Host key verification failed.
ubuntu@ubuntu-VirtualBox:~$


#5

So I ran into this same issue. What this error is saying is that you need to delete the third line of the file at /home/ubuntu/.ssh/known_hosts as it’s not the right key. Once you do that, if you try to SSH again, you will be asked to enter yes or no about trusting the key and you should be good from there. Hope this helps! :slight_smile:


#6

on the raspberry pi or the virtualbox vm?


#7

Thanks for responding @NnMm

@stephenclark that would be the virtualbox vm.