12V Main supply seems to be inactive

Hello, I powered a LiDAR Hokuyo UST-10LX using the connectors P504 (12 V aux) and P506 (GND) of the master control board of my Magni robot, to perform the power supply with 12 V of LiDAR.
It worked correctly for a while, however, during a robot startup I noticed that the LiDAR sensor did not turn on, and when measuring the voltage between connectors P504 and P506 I did not get any voltage output. I disconnected the LiDAR from the board and the LiDAR is working correctly. However, the output voltage between the connectors is still 0 V, even though there is no connection.
Is there any way to fix the 12 V output? Is there a voltage regulator that can be replaced?
The 5 V output (5 V aux) generated by the P505 connector is still working.
In the photo you can see the LED that indicates the 12 V auxiliary off.

Thank you.

The power regulators are ‘buck converters’ with very fine pitch parts at their heart. It is extremely hard to replace those. I have done it a few times and as surface mount rework goes, of which I have extreme experience, I can say that unless you have experienced SMT rework ability I would not try to replace the part.

Lets instead try something by removing a part that we have rarely found can breakdown and lead to the supply not starting because of overcurrent due to a protection diode failure. Because this is the 12V aux supply that goes nowhere this is a low risk thing to try AND we have seen this at least once so there is ‘some chance’ it may work. Not guarenteed but it could be your fastest way to a fix.

IF you feel ok with trying this then do NOT plug in your lidar after the fix until you determine if this has solved the problem and 12V Aux works again. This is the very 1st thing I would try myself as it has some limited history as being the issue. Not a certainty.


If and only if you have a SMT rework station with high temp hot air reflow then try this. If not we will discuss other approaches but this is your fastest way to address this so let me know.

Completely take out the batteries so they dont fall over when you try this. Then stand the magni up on the floor with the front of the magni on the floor. This makes the MCB back face upward.

You will have to locate D1403 which is a rather big SMT Zener diode. This part is on the back of the board fairly close to the center area but just above center. If you have a SMT rework heat gun with 5 - 10cm airgun tip this would be not too hard. D1403 is on the back and is if you looked at the back of the MCB this large diode is 5mm below the JTAG201 5-pin jack so you cannot miss this, it is easy to find and see if you have tilted the Magni like I suggest.

If you do NOT have such a heat gun it would be much more tricky. Try not to point the heat at the capacitor next to it and point the heat more towards the JTAG201 jack. You need high enough heat to melt the leadless solder so you need around 280 to 300 deg C. Many rework stations show temp in F so be aware of that.

If you are not comfortable with this we can talk more for other longer lead times ways to solve this issue.

IF you do this verify 12V aux is working WITHOUT YOUR LIDAR and only after that try the lidar again.

Attaching a picture with MCB in a Magni as I have described.

Hi Mark, thanks for the reply.
Using an SMT rework station I performed the removal of the D1403 following the suggested recommendations.
Unfortunately, there was no result, the 12V auxiliary power supply is still inactive. Can we discuss some other approaches?
The picture shows the control board with the D1403 removed.

Ok, thanks for trying. Send an email to support@ubiquityrobotics.com and in the subject put this:


In this email can you repeat the exact model of the Lidar and if you can take a picture of the wiring you described it may also offer some insight.

Please verify that if you completely remove the wires from the MCB jacks that it still does not have a 12V signal? I am thinking there is a very tiny chance of some single strand of the wire on 12V Aux bending over a slight amount and touching ground or some tiny fibre of solder that started to touch. This is a very tiny chance of this but lets just be sure of this by total removal and very clean connections where you hooked up 12V. Verify after wire removal with magnifying glass that the 12V AUX holes on the PCB are totally free of any chance of shorting because we use a very close ground plane in that area it ‘can’ happen but only with not very clean solder job.

Normally we recommend users make a crimp connector and connect to the standard older model PC 4-pin white molox connectors in your case the ‘AUX’ one.

I feel for whatever reason you do have a failure in the 12V aux supply so knowing the above things will help me decide if we can make any component changes to prevent this from happening to somebody else.

I should state that we connect our Lidars that need 12V to that 4-pin AUX jack and we have done this with at least 4 different types of lidars but maybe that one you have has some very specific high ‘inrush’ current or other thing going on if it is not the wiring itself that we are going to eliminate as the cause with this last test on your end.


We will take this up in emails now. Thanks for your great feedback and reporting of the issue.