Wifi Connection Problem

TLDR, Does having a special symbols like the dollar sign in the router password affect connecting to it using pifi in any way? If so how do I bypass this problem without changing router password?

Okay so since the start I had problems connecting the RPi to wifi. I thought it was a problem with the software so I tried some solutions found in the internet and also even reflashing the image a few times. However nothing seemed to work. So in the end I gave up on it and worked on other features of the robot while using an ethernet cable to connect to wifi to update and install packages. However, recently my boss wants me to add interfacing and control using their app so this problem can’t be ignored no longer :’) Today I had the big brain idea to maybe try bring home the RPi to see if it would connect to my home router and it did! So technically there wasn’t anything wrong with it all along. This led me to the conclusion that had always been at the back of my mind, does the special symbols in my office password affect the pifi command in any way? I have seen it affect some other terminal commands before. Is there a way to bypass this problem without changing the router password?

It sounds like the shell is trying to expand a variable in the middle of your password ($ means variable substitution on the command line). Probably the best thing to do is to wrap the password in single quotes to prevent any shell-smartness.

Something like this sudo pifi add MY_SSID 'Pa$$word'

Hope that helps


It finally works! Thank you!