WiFi access point not visible


I was trying to connect to the Magni’s network and Raspberry Pi is already installed. I am using a VM however, the Magni’s access point is not appearing on my Laptop. As stated in the last step of this tutorial, LED 1 should be blinking 15 seconds after the robot is turned on however, it is a solid blue for me. I also tried connecting a ethernet cable to the raspberry pi and my network connection cannot be detected. What tests can I do to debug this problem and see why the access point is not visible? I tried to find some documentation for connecting with ethernet instead of wifi and I couldn’t find it.

If you can detect the AP in the host OS outside the VM then you should connect to it there. Then you have to set up the VM to use a bridged network adapter so it can see the LAN. With that set up you should be able to ssh into the robot from the VM itself.

If you really need to connect it directly into the VM for whatever reason you could also use a usb dongle and set the usb to be controlled by the VM itself, but that’s not likely to be necessary.

Ethernet should work, but the Pi will be given a DHCP ip if you connect it to a router so you need to find and ssh to that IP instead. If you skip the router in between devices then it may not get an IP at all so it won’t work by default (you’d need to get inside to config it with a static ip first).

Hi @amogh.kapalli,

Would you describe the LED as dimly on? A fully on LED is quite bright and hard to look at.
The dimly on LED means that Pi isn’t booting up. Maybe try reflashing the SD card and reseating the Pi (be careful to get the pin alignment correct).

If those doesn’t work, we can discuss replacing the Pi.


Hi @rohbotics,

Thank you for your response. I tried refreshing the SD and that worked! I was able to ssh into the robot and start figuring out the mapping. Thanks for your help!


1 Like