Ubiquity "2020-02-10" image does NOT work on Raspberry Pi 4B 4GB Model

As requested by @rohbotics, I’m creating a new thread on this topic. To summarize the issue:

I downloaded this Raspberry Pi image from here:
“2020-02-10-ubiquity-xenial-lxde” (https://ubiquity-pi-image.sfo2.cdn.digitaloceanspaces.com/2020-02-10-ubiquity-xenial-lxde-raspberry-pi.img.xz)

I burned the image to a 32GB μSD card and tried the following:

  1. I could not get the Ubiquity “2020-02-10” image to boot on Raspberry Pi 4B 4GB Model connected to a monitor on my desk, ie not plugged-in to the Magni. The screen remains blank.

  2. Next, I tried booting the same 32GB μSD card with the Ubiquity “2020-02-10” image on a Raspberry Pi 3B. Works fine. No issues.

  3. Next, we happened to have have a Raspberry Pi 4B 2GB Model and it boots just fine!

  4. Finally, to convince myself that there was nothing wrong with my Raspberry Pi 4B 4GB Model, I inserted a μSD card with the stock Ubuntu 18.0.4 LTS distro for Raspberry Pi 4B model and it boots and I can login and use it just fine.

Hope that helps. Thanks -Ravi

I also use a Raspberry Pi 4B 4GB and it boots without problems.
I use the newest image from the download page (2020-02-10-ubiquity-xenial-lxde)
Did you check the checksum after downloading?

I did not check the checksum after downloading the image, but the image I downloaded (2020-02-10-ubiquity-xenial-lxde) works fine on a Raspberry Pi 3B and a Raspberry Pi 4B 2GB model, just not on a Raspberry Pi 4B 4GB model! Also verified that the same Raspberry Pi 4B 4GB model boots fine with a stock (unmodified) Ubuntu 18.0.4 LTS distro for a Raspberry Pi 4B!

Hey @ravi,

I think it is very unlikely to be a 4GB specific issue with our image, considering that is the only model we have tested with here, and @Jan also has his working.

As a standard checklist of things to try:

  • Reflash the SD card and try booting the Pi4 4GB again
  • Make sure your power supply is adequate, and all cabling is in good condition
  • Are your LEDs blinking?
  • Try both HDMI ports on the Pi
  • Try a different monitor, or headless mode (pifi should still come up)

@rohbotics, Got busy with other things. Before I retry your checklist I wanted to point out that the Ubiquity image DOES work with the 2GB version of the RPi 4 using the same μSD card, same monitor, same μHDMI to HDMI cable, etc, etc. Yes LEDs blinking on the 2GB version of the RPi 4, but not on the 4GB RPi4!

If I swap-out the Ubiquity μSD card with a Ubuntu 18.0.4 LTS μSD card, the RPi4 4GB boots just fine. Very strange. I will reflash the Ubiquity image and try again, will report back.

1 Like