Trouble SSH into Pi image on Rpi 3b


Thank you for the response. I got around to starting to need to use ROS on a Pi, but I encountered an error when trying to SSH into the machine.

I used the most recent Pi Image from the website you provided: 2020-11-07-ubiquity-xenial-lxde-raspberry-pi.img.xz

and I successfully used etcher to load it onto a microSD card.

The Pi I am using is Pi 3 Model B and it appeared to boot fine and created the wireless access point. I connected to the network, but then got an error. Please see the attached screenshot.

I got this error using the Pi’s name and also the ssh ubuntu@

I then added the key “SHA256:Cw…AM” to the .ssh/known_hosts file, but still get the same error. Please let me know what I am doing wrong.

I seem to recall seeing this in the past in the case where I connected to one pi using ssh but then later used an entirely different PI on different image and got this. It is I think because you already have a key but it was for some OTHER Pi you had used before at same IP or name (
So on your linux machine use that ssh-keygen line they say to use for removing this older key.
Then try another ssh session and it will setup the current key that gets setup for the
I run into this when I have several machines or even one in the past that was ubiquityrobot.local

It is for this reason that we say it is best to rename your pi hostname to avoid multiple ssh keys and other things for different machines but they have same name.

1 Like

Thanks for the response! Using that command worked.

I did previously connect to the previous project group’s Pi3B+ that has the same name and IP and is mounted on the mobile robot platform. I decided to download the Pi image to develop software on my own Pi 3b so as to not mess up what the previous group worked on until I figure out how to add to their code or integrate my code.

This is a SUPER common issue and no problem. Glad you are back ‘on the air’.
That is the reason for the brief line on the console telling you to do that ssh key removal but it does not explain the most likely reason it is needed which I have explained above We are not in control of that prompt so it is part of Ubuntu and the SSH stack. Take care and enjoy Magni AND the image!