Roslaunch Magni Rviz

Hi All,

I’m new to here and I had loaded the Ubuntu image onto Virtual box and tried to Visualise with Rviz,

command: roslaunch magni_viz view_robot.launch

and I got this error below: (launch file not found…)

is there a specific directory that I need to be in to launch magni_viz? or please

advise,

Thank you,

Roger

Hi @inmoov,

Try installing the magni packages manually, sudo apt install ros-kinetic-magni-robot

Hi @rohbotics,

I tried that command, and this what came below:

Please advise, (am confused…) , thanks

Can you run sudo apt update and then run the install command again?

Looks like you are on old versions of packages.

Rohan

Hi @rohbotics

I have done the update as you said and ran the install command again, still same thing,

please advise, (see below, this is also the image I downloaded for Virtualbox on the UbiquityRobotic website, as I’m confused as to why it is not up to date…)…

Hi @rohbotics

Are you able to assist me please?
Am still lost here,

Thanks

Hey can you try running roscd magni_viz; cd launch; ls as a test to see if the launch files are actually there or not.

There have been some cases in the past where reinstalling or updating packages resulted in missing files for some reason, though it was usually python scripts.

If all else fails you can always make a new catkin workspace and clone the packages from github, that should give you the latest versions and make sure that nothing’s missing.

Hi @MoffKalast,

Yes I tried roscd magni_viz and see below :

So I ended up creating a catkin_ws workspace and followed the instructions for RVIZ, (link: https://learn.ubiquityrobotics.com/rviz)

RVIZ fires up and when I clicked on the black spaces with the green arrow posing, Magni does not move?

Another question is, do I need to connect to the actual Robot Magni first for this to work?

Thanks

Yes, rviz merely visualises the data already present in the system. If a robot is connected then it’ll display the robot’s data, otherwise you need to launch the gazebo simulator which will provide data for a virtual one.

Thank you @MoffKalast, I think I found this link https://learn.ubiquityrobotics.com/simulation ,will give it a go and let you know if I run into any issues.

Hi @MoffKalast,

I launched gazebo and it looks ok with the controller pad,

but when I click on RVIZ, it looks like this below (with errors)

any advise please on the errors?

Thanks

Hmm well it would appear that Rviz is not receiving the needed transform frames. That usually only happens while Gazebo is still initializing, so i’m not entirely sure what’s going on here.

Does the robot show up in gazebo fine and can drive around? I’d imagine there may be an issue with the robot model package.

I think you still may be missing packages.

Please run these commands (needed because ROS changed gpg keys):

sudo apt-key adv --keyserver 'hkp://keyserver.ubuntu.com:80' --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654

sudo apt-key del 421C365BD9FF1F717815A3895523BAEEB01FA116

And then install updates

sudo apt update
sudo apt upgrade

Hi @rohbotics,

I tried your commands and now I get this message straight after the sudo apt upgrade command:

If I click ok on both options here, I get this:

continue without installing GRUB, yes or no

Please advise,

Thanks

I think you can just select the first option.

@rohbotics ok, I selected the first option , next screen is “continue without installing GRUB” do I click yes or no?

thanks

@rohbotics , I have included screenshot as well,

Ok if you ask me there’s something seriously wrong with your vm image in general, it may be less time consuming to simply grab a clean Ubuntu 16 image, install ros kinetic and then the ubiquity packages than continuing to debug this.

yea, but it is not my vm image, I downloaded from the UbiquityRobotic website in the download section, I didnt set this image up, so I thought this image would be ready to use after deploying into Virtualbox…, but it seems not the case which is frustrating…,

Hi @rohbotics,

Any updates on this one?
thanks