ROS image on Raspberry Pi 4?

I was searching for a precompiled image of Ubuntu and ROS Kinetic for RPi4 and came across this (as it was a pain in the ass to compile ROS from source on rasbperry).

I’ve just booted the RPI4 with the image and successfully connected it to our wifi. However, I tried disable the Wifi and connected it with a ethernet cable, but that didn’t work.

Another thing that might not corresponds to the actual image, but I wasn’t able to contact the ROS master running on my PC in the same network. However, I was able to ping the PC from the RPi4.
The following config was used:

export ROS_IP=

export ROS_IP=

I’ve also added each IP in each corresponding /etc/hosts file.

However, the opposite setup works, by letting the RPi4 acting as the master and the PC the slave.
Then Im able to see the rostopic list from the PC.

BR Robin

Problem solved with the communication, as I mentioned it didn’t correspond to the actual image. The problem was on my PC!

However, I would like to figure out why the ethernet doesn’t work!

Hi @r91,

Thanks for the testing. What are you trying to connect the ethernet to? I have had success with ethernet, so it might be something more subtle.

Also for the ROS master stuff, the image boots up running its own roscore. You should disable these services if you are not on a Magni. sudo systemctl disable magni-base; sudo systemctl disable roscore.

Yeah I’ve had the same problem myself. The new images seem to never quite connect to ethernet unless you completely reconfigure the networking setup. I assumed this was by design.

I have just installed the image on Pi4 and am attempting to connect to host machine running the Ubiquity Virtual Machine. I am unable to see the Pi Image from host machine’s WiFi but followed this tutorial:

is there any additional steps for the Pi4 image? I am able to start the ubiquityrobotXXXX connection using the given password but it is not being discovered by other WiFi adapters.


What do you mean by I am able to start the ubiquityrobotXXXX connection using the given password? Is the network being seen by some machines and not others?

Or do you not see the network name in the VM? Even if you don’t, as long as the host is connected and the VM is in “bridge mode” you should be able to talk to the Pi.


From the Pi Robot side, the Wi-Fi network that comes pre-setup (ubiquityrobot38CA) is intermittent. If I reboot, it will temporarily be displayed and I am able to connect from host machine. At the moment, I successfully setup the connection between host (windows 10) and the Pi. On virtual box using the ubiquity provided ubuntu image, I have the bridged connection set up with the wireless adapter and I am unable to ssh to the Pi using the tutorial. I’ve tried
ssh ubuntu@ubiquityrobot.local

Thanks for fast response!

Success! I finally was able to connect, I had to sudo ssh and then deal with the ECDSA key error by deleting a key from known_host. Thanks for your help! I’m looking forward to playing with the RPi4 image.

Hey there, we successfully installed the image, on the PI4 and Networking is working 95% of the time.

But we want to use this GPS Module. We followed these instructions . We are getting some GPS message, but when we use cgps -s we are not getting anything. The timer, for the Fix doesn’t even start.

Does someone have the same GPS Module and could provide some information, if it is working on ur side?

PS:On PI3 it was working flawlessly

Hey @robson90

Could you ask your question in a new thread so that we don’t continue to pollute this thread (and blast out emails)?

I would be happy to help you in a new thread.

Ubiquity Robotics

I have your image installed and I added a 5G ac wifi adapter, and one more time Yea! You did it!!

1 Like

I installed ntpdate to get timing and date issues fixed and we are good to go.

Hi everyone,

I seem to be having issues upon startup logging into the pi via SSH. I have turned off the pi’s onboard wifi and connected to a local network as I will need to command multiple Pi’s and figured going through a router was the way to go. If I try after booting up the pi I always seem to get the following error.

ssh: connect to host testcar.local port 22: Connection refused

Then after a certain amount of time (roughly 5-10 minutes) I am able to log in without any issues. Does anyone have any ideas as to why this happens and how to fix it? Thank you all for your time!

can i use robot commander app for my small robot 2wd just for movement control using rpi 4 and L298 motor driver or i need to do changes if yes please suggest what changes need to be done in ros

Is Pi4 officially supported now? The download page still just says 3b and 3b+ and someone was asking me about official pi4 support.

Hey @tlalexander

We officially support the Pi 4 now! The downloads page has been fixed.


So, I downloaded the “2020-02-10-ubiquity-xenial-lxde” ( image from your “Raspberry Pi Images” downloads page, flashed it onto a 32GB μSD card successfully and tried and failed to boot to it on my Raspberry Pi 4B 4GB model! FYI, I’ve been using that Raspberry Pi 4B 4GB model for several months now just fine. It boots from a different 32GB μSD card with Ubuntu 18.04 LTS on it.

Next, out of curiosity, I tried booting the same 32GB μSD card with the “2020-02-10-ubiquity-xenial-lxde” image on a Raspberry Pi 3B and it booted without a glitch! How do you explain this?!

Has anyone tested it with the RPi 4B 4GB model? FYI, none of the Ubuntu stock ARM kernels supported 4GB memory for 6+ months after the RPi 4B was released! The Raspbian kernel did support it at release time, but none of the major RPi distros supported exploiting all 4 GBs. There were some hacks for a few months that supported upto 3GBs of out of the 4GBs, etc until a full fix was released sometime in Dec 2019 I believe.


Hello @jbatt,

I had the same problem and I was able to solve it in the following way:
sudo nano /etc/systemd/system/

In this file change line



Hi @ravi,

It boots for me and others at Ubiquity Robotics on the Pi 4B 4GB just fine, we use the Kernel from Raspbian because they better support the Pi hardware while Ubuntu is often very behind.

Can you connect a monitor to the Pi and see if any output comes up at all? That would be an important step in debugging this for us.

Also I would appreciate it if we moved this conversation to a new thread, so that everyone on this thread isn’t notified if we have to do several rounds of debugging.

Ubiquity Robotics

Hey @jan,

Thank you!! That solves a very annoying problem for many users in a very simple way, thanks for digging that out.

We will incorporate that change into the next image.