ROS image on Raspberry Pi 4?

Yes that is what you would need to do right now. Unless you absolutely have to I wouldn’t say I recommend it at the moment.

Thanks for the previous treads,
Now is the wifi access possible with the rpi 4 ?


any one worked on wifi ? i tried

this output based on raspberry pi 3

> dmesg | grep brcmfmac
> [    5.028837] brcmfmac: F1 signature read @0x18000000=0x15264345
> [    5.032981] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
> [    5.033260] usbcore: registered new interface driver brcmfmac
> [    5.213328] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
> [    5.229240] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar  1 2015 07:29:38 version 7.45.18 (r538002) FWID 01-6a2c8ad4
> [    8.811026] brcmfmac: power management disabled

My 2 cents.

We had to order 55 raspberry pi 3b+ yesterday for a completely unrelated project.

None of our usual 5 suppliers in France (online eu e-resellers) had the complete quantity on stock. The answer they gave us was “sorry no more stock, we sell only pi4 now”

We ended up empting the stock of various resellers on Amazon FR marketplace

I would encourage to get a native image for pi4 now

Update on the status of this,

Using updated firmware files for the brcm43455 I was able to get wifi working on the Raspberry Pi 4. Woohoo!

Unfortunately, AP mode still isn’t working so I need to investigate that some more.


Great work on the Pi4 work. The extra power will be great work with. Call out if we can help with testing etc.

Yes it would be great to get your help. The key question is whether AP mode for the RPi 4 can be made to work in any configuration. So for example can you bring up AP mode on raspbian? If you can then we can probably bring whatever modifications exist on Raspbian to our Ubuntu build.

Some guidance as to how you managed to do this would be greatly appreciated.

Hey All,

Here is a link to the Raspberry Pi 4 image with no AP mode

I am looking into trying to get AP mode working, but any help would be appreciated.

So I gave this a shot, so far so good except for the included version of pigpio which is v50. The Pi 4 apprently requires a version above v69 to run properly. Anyhow the included one doesn’t seem to do anything at all so you need to compile from source get any kind of motors working. Luckily it takes like 1 minute to compile, unlike ROS hah. Just FYI.

Thanks for doing that testing @MoffKalast, I will see how we can get an updated pigpio version for the new image.


Neat. Btw, what is the issue that is blocking you from making an access point?

Mostly asking because I can’t seem to make wifi work properly even in client mode with a static ip. I’ve tried the /etc/network/interfaces declaration way which didn’t connect at all, now I’m using the network manager set to connect with a static ip, which does connect, but no traffic gets through. Pinging the router gives destination host unreachable somehow. Did you manage to make this part work or is wifi shot in general?

I’m used to the raspbian way using wpa_supplicant, but I can’t seem to find an ubuntu equivalent if there even is one. Supposedly /etc/network/interfaces is all that should be needed?

Hey @MoffKalast,

We use NetworkManager instead of /etc/network/interfaces. Make sure that you don’t have anything wifi related in your /etc/network/interfaces, and then you can use nmcli to manage networking. (you should be able to find how to setup static ip with NetworkManager online).

You can also get everything working under /etc/network/interfaces if you want, but you run into issues.

I am able to connect to wifi networks using nmcli on my Raspberry Pi.


1 Like

Ah I see, my mistake was managing ethernet through interfaces and wifi through NetworkManager, so even if the cable was unplugged eth0 somehow took precedence and sent all packets to ethernet. I’ve set them up both through nmcli now and it seems to work.

Edit: Also worth for anyone that comes across this, the wifi doesn’t connect until you login unless you go to /etc/NetworkManager/system-connections/, find a file with the same name as your wireless network and change the line permissions=username; to permissions=

Thanks :smiley:

Bringing this back on topic. If anyone can see if they can get AP mode working using hostapd and the rest of the non-NetworkManager things, let me know. I am not sure if my setup is wrong, or if it is just not working.

@MoffKalast Glad you figured it out. You were probably missing allow-hotplug for the ethernet in your /etc/network/interfaces.


Hey all,

Just an update on this. @MoffKalast has found a solution for getting AP mode working on the Raspberry Pi 4. A newer version of hostapd is needed. We are working on a backport of the version from Ubuntu Bionic.

We would still like to do some more internal testing, but if anyone needs functioning AP mode and is willing to endure some beta testing let me know.


1 Like

I found a way to update the PIGPIO. this is their website, I followed method 3, my GPIOD version is v73 now. Haven’t figured out how to active AP mode.

1 Like

Hi @NolanIndustry,

Thanks for the tip! We will be including an updated pigpio version for the next version of the image.


Hello everyone, we’ve just built what should be a fully working Pi 4 image with fixed AP mode, fixed camera sudo issues, and updated pigpio:

We’ll be testing it the next few days to see if everything checks out, but if anyone wants to try it themselves be my guest.


Wonderful, thank you! I will be trying it out as soon as possible!