ROS image on Raspberry Pi 4?

So I gave this a shot, so far so good except for the included version of pigpio which is v50. The Pi 4 apprently requires a version above v69 to run properly. Anyhow the included one doesn’t seem to do anything at all so you need to compile from source get any kind of motors working. Luckily it takes like 1 minute to compile, unlike ROS hah. Just FYI.

Thanks for doing that testing @MoffKalast, I will see how we can get an updated pigpio version for the new image.


Neat. Btw, what is the issue that is blocking you from making an access point?

Mostly asking because I can’t seem to make wifi work properly even in client mode with a static ip. I’ve tried the /etc/network/interfaces declaration way which didn’t connect at all, now I’m using the network manager set to connect with a static ip, which does connect, but no traffic gets through. Pinging the router gives destination host unreachable somehow. Did you manage to make this part work or is wifi shot in general?

I’m used to the raspbian way using wpa_supplicant, but I can’t seem to find an ubuntu equivalent if there even is one. Supposedly /etc/network/interfaces is all that should be needed?

Hey @MoffKalast,

We use NetworkManager instead of /etc/network/interfaces. Make sure that you don’t have anything wifi related in your /etc/network/interfaces, and then you can use nmcli to manage networking. (you should be able to find how to setup static ip with NetworkManager online).

You can also get everything working under /etc/network/interfaces if you want, but you run into issues.

I am able to connect to wifi networks using nmcli on my Raspberry Pi.


1 Like

Ah I see, my mistake was managing ethernet through interfaces and wifi through NetworkManager, so even if the cable was unplugged eth0 somehow took precedence and sent all packets to ethernet. I’ve set them up both through nmcli now and it seems to work.

Edit: Also worth for anyone that comes across this, the wifi doesn’t connect until you login unless you go to /etc/NetworkManager/system-connections/, find a file with the same name as your wireless network and change the line permissions=username; to permissions=

Thanks :smiley:

Bringing this back on topic. If anyone can see if they can get AP mode working using hostapd and the rest of the non-NetworkManager things, let me know. I am not sure if my setup is wrong, or if it is just not working.

@MoffKalast Glad you figured it out. You were probably missing allow-hotplug for the ethernet in your /etc/network/interfaces.


Hey all,

Just an update on this. @MoffKalast has found a solution for getting AP mode working on the Raspberry Pi 4. A newer version of hostapd is needed. We are working on a backport of the version from Ubuntu Bionic.

We would still like to do some more internal testing, but if anyone needs functioning AP mode and is willing to endure some beta testing let me know.


1 Like

I found a way to update the PIGPIO. this is their website, I followed method 3, my GPIOD version is v73 now. Haven’t figured out how to active AP mode.

1 Like

Hi @NolanIndustry,

Thanks for the tip! We will be including an updated pigpio version for the next version of the image.


Hello everyone, we’ve just built what should be a fully working Pi 4 image with fixed AP mode, fixed camera sudo issues, and updated pigpio:

We’ll be testing it the next few days to see if everything checks out, but if anyone wants to try it themselves be my guest.


Wonderful, thank you! I will be trying it out as soon as possible!

I was searching for a precompiled image of Ubuntu and ROS Kinetic for RPi4 and came across this (as it was a pain in the ass to compile ROS from source on rasbperry).

I’ve just booted the RPI4 with the image and successfully connected it to our wifi. However, I tried disable the Wifi and connected it with a ethernet cable, but that didn’t work.

Another thing that might not corresponds to the actual image, but I wasn’t able to contact the ROS master running on my PC in the same network. However, I was able to ping the PC from the RPi4.
The following config was used:

export ROS_IP=

export ROS_IP=

I’ve also added each IP in each corresponding /etc/hosts file.

However, the opposite setup works, by letting the RPi4 acting as the master and the PC the slave.
Then Im able to see the rostopic list from the PC.

BR Robin

Problem solved with the communication, as I mentioned it didn’t correspond to the actual image. The problem was on my PC!

However, I would like to figure out why the ethernet doesn’t work!

Hi @r91,

Thanks for the testing. What are you trying to connect the ethernet to? I have had success with ethernet, so it might be something more subtle.

Also for the ROS master stuff, the image boots up running its own roscore. You should disable these services if you are not on a Magni. sudo systemctl disable magni-base; sudo systemctl disable roscore.

Yeah I’ve had the same problem myself. The new images seem to never quite connect to ethernet unless you completely reconfigure the networking setup. I assumed this was by design.

I have just installed the image on Pi4 and am attempting to connect to host machine running the Ubiquity Virtual Machine. I am unable to see the Pi Image from host machine’s WiFi but followed this tutorial:

is there any additional steps for the Pi4 image? I am able to start the ubiquityrobotXXXX connection using the given password but it is not being discovered by other WiFi adapters.


What do you mean by I am able to start the ubiquityrobotXXXX connection using the given password? Is the network being seen by some machines and not others?

Or do you not see the network name in the VM? Even if you don’t, as long as the host is connected and the VM is in “bridge mode” you should be able to talk to the Pi.


From the Pi Robot side, the Wi-Fi network that comes pre-setup (ubiquityrobot38CA) is intermittent. If I reboot, it will temporarily be displayed and I am able to connect from host machine. At the moment, I successfully setup the connection between host (windows 10) and the Pi. On virtual box using the ubiquity provided ubuntu image, I have the bridged connection set up with the wireless adapter and I am unable to ssh to the Pi using the tutorial. I’ve tried
ssh ubuntu@ubiquityrobot.local

Thanks for fast response!

Success! I finally was able to connect, I had to sudo ssh and then deal with the ECDSA key error by deleting a key from known_host. Thanks for your help! I’m looking forward to playing with the RPi4 image.

Hey there, we successfully installed the image, on the PI4 and Networking is working 95% of the time.

But we want to use this GPS Module. We followed these instructions . We are getting some GPS message, but when we use cgps -s we are not getting anything. The timer, for the Fix doesn’t even start.

Does someone have the same GPS Module and could provide some information, if it is working on ur side?

PS:On PI3 it was working flawlessly