Pifi on Focal amd64?

I really like your Pifi package. Is it possible to install it on a 64 bit Focal?

I get an error on your keyserver?

ubuntu@ubuntu:~$ sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key C3032ED8
Executing: /tmp/apt-key-gpghome.tJyRa3Hi7w/gpg.1.sh --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key C3032ED8
gpg: keyserver receive failed: No name

Yeah we’re getting that error as well, unfortunately the guy in charge of that system (@rohbotics) is otherwise occupied at the moment and hasn’t been able to look into it yet. Same goes for all other packages on focal.

In the meantime you can always grab it on https://github.com/rohbotics/pifi and compile it locally (should be as simple as sudo pip3 install .), assuming you get all the dependencies in order.

1 Like

Thanks, it failed to compile with a bunch of errors, so I went with https://github.com/balena-os/wifi-connect#installation as an alternative.

If you install a desktop, you don’t need Pifi, and if you start with an ARM64 Focal server, you can enable WiFi via the CLI. If I remember once Ubuntu went to focal, they don’t use nmcli, and there is a different way to enable wifi.

1 Like