Not enough space in /boot

I am trying to update my ubuntu system on the pi, but I always get a message mentioning I need more space on my /boot. I tried deleting some files, but that doesn’t work. Is there a way i can resize the boot file?

EDIT: the solution for this as @anfederman mentioned is to increase the boot size. You can use either a fully fledged ubuntu system, i.e. a machine running ubuntu, or a raspberry pi with an sd card usb adapter (this was an expensive option for me, and I had some old computers. So, I went with the second option)

To do this:
1 - install gparted on ubuntu system using: sudo apt-get install gparted
2 - make sure you have latest version of e2fsck e2fsck -V (if not, use this tutorial)
3 - follow this tutorial it explains it very nicely and clearly.

EDIT 2: fair warning, when I attempted to change the bootsize after initializing and updating, it didn’t work. So, I had to resize the partition before booting up the pi for the first time

That should be it! Good luck and happy developing!

This was a complex issue we too hit on our prototype 20.04 images that are coming along nicely by the way. I am not the ‘Pi Image Guys’ so I cannot say specifically what they did but they solved the issue in some ‘clever’ way. Perhaps they will ‘chime in’.

We are not ready to post a date we commit to 20.04 on Magni but it grows closer by the week with a great deal of progress so far. Not done yet but MANY things are falling into place.

Beside drivers and the kernel and so on a HUGE issue is a great deal (all) of our python had to be fixed so it works on Python 3 which is now basically ‘clearly the only supported path’ on 20.04.


The way I did it was to take the SD card out of the PI, put it on a Ubuntu machine and used gparted to add 100meg to the boot partition. You need to move the root partition a bit.

1 Like

Thank you so much for both of your replies!! I’ll let you know how it goes

For some reason I can’t adjust the size of the root partition, did you face that issue?

I am getting this error:

Check and repair file system (ext4) on /dev/sdb2  00:00:00    ( ERROR )      calibrate /dev/sdb2  00:00:00    ( SUCCESS )      path: /dev/sdb2 (partition)
start: 125001
end: 33681407
size: 33556407 (16.00 GiB) check file system on /dev/sdb2 for errors and (if possible) fix them  00:00:00    ( ERROR )      e2fsck -f -y -v -C 0 /dev/sdb2  00:00:00    ( ERROR )      e2fsck 1.42.13 (17-May-2015)
/dev/sdb2 has unsupported feature(s): metadata_csum
e2fsck: Get a newer version of e2fsck!

I used this command to install e2fsck

Should I install e2fsck on the pi itself?

EDIT: I actually had to update it on the ubuntu machine itself. The link I used: Updating e2fsck

Sorry, I just need to ask a small question which is did you change the type of the storage from fat16 to fat32?