Motor Not Responding

Hi folks,

We have just experienced a loss of comms with the magni-serial connection. I can confirm this from the lack of publishing to the “diagnostics” topic, manually starting magni throught the base.launch file, and following your troubshooting guide (including the test script) - no comms.

Motors are powered fine (we can feel the resistance).

Everything on this system has worked fine for months. No recent changes or software updates, just out of the blue stopped working.

Is there anything else to check that can cause a sudden loss of serial comms? ie. fuses? connection?


We have one known issue that we very recelty found a good solution for fixing. This comm issue symptom is both the SIN and SOUT leds at the top of the board blink but motor node will not start. The ~/.ros/log/latest/rosout.log gets massive numbers of logs to it that contain the word ‘REJECT’ in upper case.

If this is your issue then as root use sudo vi /boot/config.txt
Then find and uncomment out the line and use value 38400 like this:


If this is your comm issue then the above would be the fix.

If your symptom is different then report back to me if you see BOTH tiny leds of SIN and SOUT blinking at a high rate and both bright. These leds are at the top of the MCB near center front of the board at top.

Next report if you see the 3.3V led on very bright and this is about 2cm below the large white ‘MAIN’ power jack.

Thanks Mark - the device is getting shipped back to us at the moment. I soon as I have it back in my hands I will test for this.


Hi Mark,

The SIN and SOUT lights are blinking at a very high rate (almost appear solid) and are both bright.

The 3.3V led are on and bright (similar brightness to other LEDs).

One thing to add - the motors appear to be connected but without power - ie. the state they are on when the board is powered, but the motors are off. In this state the wheels can be turned with some resistance.


Ok so please use sudo vi /boot/config.txt then uncomment/modify init_uart_baud
After saving this do full ‘sudo shutdown -r now’ so it takes effect.

The lack of motors being held firm worries me the most.
Verify the blue led on lower right is on solid which indicates live motor power.
This led is the only one there but FYI has label ‘24V_MOTOR’
I will assume the estop switch is in ‘out’ position and big RED led on switch board is on but verfiy that is ok if the blue 24V_MOTOR led is off.

If motor power is really on do this command and see if it says ‘True’
rostopic echo /motor_power_active

Hi Mark,

24V_Motor LED light is not illuminated, and rostopic echo /motor_power_active data : false.

Interestingly enough, when you move the robot forward, the wheels will generate enough power to make the /motor_power_active data = true.

Ok, this is a good observation and lines up with all you have said.

Yes the wheels act as generators so do not worry about that but yes, it is ‘interesting’.

Do you have some other switch board you could swap into this unit and try?
You have not said if the big red led on the switch board follows the position of the ESTOP red switch or not. When the big red led goes ‘on’ the blue motor power led on the right is supposed to activate due to motor power being on.

Tell me again what version is that MCB? A great many changes went into the versions of the MCB to fix issue that used to be very much more common where the ECB (Electronic Circuit Breaker) had problems but most often it would short in the always on mode and in your case it is always off.

We have had other issues but rare with a tiny zener diode failing that led to no motor power.

Hi Mark,

We tried a new switch board with different power settings (ie. red/black buttons in different positions) - all with the same result. The MCB version is 5.3.


Please contact me through email to so we can treat this as some sort of likely field failure. Sorry for your issues here.