Magni Occasionally Fails to Start

I was able to capture the log (from sudo journalctl -u magni-base) this morning, but we experience a magni startup failure on 1/5 starts.

Please see the attached image. Looking deeper in the code, it looks like a Firmware Version error that is causing this, but again - not sure why this works 4/5 times!

Thanks in advance,

Hmm, which firmware version are you using? This looks a bit more like an MCB failure than outdated firmware, but it would be a good idea to update just in case it helps.

sudo systemctl stop magni-base
roscd ubiquity_motor
python2 scripts/ --file firmware/v43_20210829_enc.cyacd

Might also have something to do with the Pi image you’re running, we used to have a problem where the default baud rate persisted but only sometimes, so you really need to have init_uart_baud=38400 in the boot config.

At the end of this year we found that there was this case where the Ubuntu OS came in and reset the serial port to a different baud rate sometimes after we had set it to 38400.

To fix this required a change to the image where we set the port default baud rate for Linux to also be 38400 so that when this race condition happened it would do no harm. I must try to track down this fix in order to be of help here. I do not know which image(s) have the fix for this but in any case if this somehow ‘regressed’ recently in the images we do need to address it.

Please post in THIS thread the exact image you are using boarderkris. Sorry this is causing some grief but we do have a fix.

Give us a couple days to track this down. This was a linux side software issue for images and has only been recently fixed like in last 4 months.

Perhaps this will jog Vid’s mind on this but I will track it down with him.

Also as was mentioned you really should run v43 firmware on the MCB if that is not already what you are running but what you describe is in fact a linux race condition.

Ok, I am just starting to poke around in my notes. This sounds like what I recall but I will find a better more confirmed document to verify this. Try this in the mean time as it sounds about right for what I did for this race condition:

/boot/config.txt has an option commented out of init_uart_baud=115200.
To fix your issue you should set init_uart_baud=38400

See if you do NOT have this as default of 38400 system baud rate and change yours for this value which may fix this issue.


Found the earlier issue here and yes, above fix is in new images but not in non-noetic images I suspect so would be done manually. Full issue is here:

Thank you Mark and Moff for the promt responses.

We are a little behind on our firmware version: v40_20201209_enc.cyacd, but we had believed it was stable - although I’m questioning that now, as we do have automated software to reset magni-base if there detects an issue.

In the /boot/config.txt file , the line init_uart_buad is commented out as:
I will try that as well.

We are also still on kinetic, however looking for an excuse to move forward to Ubuntu 18 or 20, so perhaps this is the time.

All Kinetic images never had this fix. It was a tricky problem that took quite some time to finally figure out the fix. Sounds like you are covered at this time.

Thanks Mark.

We will be updating to Noetic very soon!

Just to confirm - the latest “THIN” wheels definied earlier, are still suppored in the latest version?