How re-enable Access Point mode on the Raspberry Pi (RPi)?

I followed your documentation to connect the RPi to an external WiFi SSID using the pifi utility. Doing this disables the Access Point mode the RPi was setup out of the box. Question is, how do I re-enable the Access Point mode on the RPi. Scoured your docs and couldn’t find a reference. Thanks in advance!

Well if you have a magni robot with a sonar board attached you can press one of the two buttons to enable AP mode.

If using the image by itself then you have two options:

  • move pi out of range of the network before turning it on, in that case AP mode goes up automatically
  • ssh into the pi through the network and run pifi remove <networkname>, then reboot

There’s a feature request for pifi that would just turn on AP mode through terminal commands, but it’s fairly low priority.

For a robot with a sonar board attached, pressing the button labeled “SW2” starts AP mode.

The Pi cannot act as an AP and a client at the same time, so pifi only starts AP mode at bootup if no known networks are found.

Great. Thanks MoffKalast & Rohbotics!