Getting errors in recent pip version

Hello there!

Recently, I’ve been trying to use some new python libraries for a project I’ve been building, and when trying to install these libraries, pip asked for an upgrade, from version 8 to version 21. As that was done, the pip packages went completely crazy - every single thing that was tried to do with pip, even simply typing “pip” itself, was responded with an error that “the ‘typing’ packages couldn’t be found”. This issue was only solved by deleting every single thing pip in the system and re-installing them all again.

After some research, I believe that’s because the Ubiquity OS is using Ubuntu 16.04, which uses Python 2.7, that’s not supported by recent pip versions. However, now every time we try to use pip, it asks for an upgrade. Are there ways to solve that, or plans to move Ubiquity to a new OS that has Python3? How can we avoid this issue for now?

Thank you in advance!

Well there are a few ways of going about it, but the most recent pip version you can run on the kinetic image is 20.something.

I’ve found that using the script to reinstall it seems to be able to resolve it regardless of what was messed up before, so I’d recommend using that.