CONVEYORBOT software with STag

So, I am using a default magni silver. I attached it to a lcd and tried to run the CONVEYORBOT software. I have put the HD15 000 and HD 17 000 in font of the camera, but there is no response.(It said nothing detected) I did add a path that should follow 000. Thing just didnt work out.
Is there any detail description on how to set the things up and make magni silver follow the STag?
(I dont have the fiducial stickers comes with the package. I only bought the software.)

Conveyorbot is very very new. We have the intention of making it able to do things like you are discussing but our priority at this time is to form a reliable Conveyorbot system with known and defined physical and software system components.

We have been doing extensive testing and finding and fixing limit cases and cases where it does not turn smootly. This is a HUGE effort but it looks better and better each few weeks.

One thing that I have done was to try to place the raspicam in a very similar pose relative to the robot. This is not too hard to do if you attach an aluminum upward angle iron centered on the front of the magni silver and have it about the height of the camera for the real Conveyorbot as well as pointing ‘downwards’ at about the angle of the Conveyorbot camera. I don’t have one here now as it is being used by somebody else right now or I could measure these things but the height above the floor is ‘about’ 30cm and the angle downwards (this is a big guess) is downward about 35 degrees??? The yaml file for the robot is in the software and describes the exact height (above base link) and angle down about the axis.

The markers that are used are in a big PDF file and are called ‘stag’ markers’. Somebody else will have to supply those, I don’t have the latest handy nor do I know the version of the stag marker library that matches your software. Again, all this is a fast moving thing, we are close to a rather finalized system of hardware and software but some changes ‘can happen’ still. Conveyorbot is not using the checkerboard floor markers. You will have to print the markers to the same size.

So I think I am saying you are a bit ahead of the curve to be trying to make a Magni make this as we do not really have this well enough documented for that situation (I may be wrong but ‘think’ this is the case).

Sorry, i got some process and those question are not a problem anymore, but i would like to know that how the route setting actually work. It says it will follow certain number and i see on the screen it detect those number. However, with the motor working, it dont move.
How can i set the marker with other movement(like following it.) I have used 4000 which is go but it didnt move.

(One irrelevent question about markers. Is these markers the same as the AR markers in EZ map? Where can i find it?)

Hi ryan,

I recommend that you use HD11 library of markers, that’s what we use. If you want to use a different library, you should edit the file breadcrumb/breadcrumb_detect/cfg/single.yaml, where you have to specify which HD library are you using. The default is 11.

To see which marker numbers represent which marker type, look at the mapping in breadcrumb/ground_fiducials/cfg/pack-info.json

I also recommend that you read these instructions if you haven’t already: Main Menu | ConveyorBot - Ubiquity Robotics’ Conveyor Robot

Thank you for your information. It helps a lot.
I would like to know, for the fiducial markers, is it used with some outer part? (Sth like red/purple/blue/green in Navigation Software - Ubiquity Robotics )
I am asking this because now i got everything set. The robot can detect the number of the markers but it wont do anything.
Is it suppose to used with the outer part?

Technically, you don’t need the outer part, but if you won’t have it, it will be a bit harder to see in which direction the robot will go and which type of marker is it
If you want the robot just to move, you should print some “GO” markers, which have range between 2000 and 6999. and place them in front of the robot one after another. Then place the robot so that one marker is visible and press START on the touchscreen and the robot should move.
Also, when you are printing markers, its recommended that the black square in which there is the marker image should have sides of length 18cm. That’s how its configured now.

1 Like

But it didn’t move when it detected 4000. Is it because of the orientation?

It might be, yeah. GO markers are ignored if they are pointing in the direction of the robot. They must point in the direction away from the robot.

Thank you for your suggestion, but i tried with the official fiducial stickers with all the orientation and it still didnt move. The camera can detect it and show the correct numbers, but the robot still didnt move at all. For the stop signal, it can detect it show some related notice. I have tested with the wheels too. They are working just fine.
Do you guys have any idea on what happened?

Can you send a picture of how you mounted the camera? This is very important, it has to be on the appropriate height and also tilted for appropriate angle.

Thank you for your suggestion. Is it the height above the floor is ‘about’ 30cm and the angle downwards (this is a big guess) is downward about 35 degrees? Just want to make sure before i do anything.

This is not ideal, because detection node is calibrated so that the camera should be quite higher than 30cm. But, the robot should still start driving also in your case. Can you send the logs? Please zip the folder ~/.ros/log/latest and send it after you have tried pressing start in front of the marker.