Connecting to Robot using WSS

We are trying to use speech commands to navigate to way points ,Is there a way to use microphone on chrome browser

File attached

We tried the instruction given

@rohbotics Could you please give us some helping pointers

Well the preferred way to do this is to use the robot commander android app. The web-app is deprecated.

As for chrome you may wish to check chrome://settings/ …advanced … Privacy and Security … content … to make sure that the site is authorized.

We are doing code changes to speechcommands.html in adding some of the logic related to IOT .With android app we do not have source unlike speechcommand.html
Is there a way to get and rebuild android APP source ?

Check out

HI @davecrawley

Fundamentally chrome allows mics and camera only with security https or wss but for some reason we cannot bring up the chrome browser with robot ip in https or wss mode

We tried chrome command line argument --ignore-certificate-errors as well

As discussed on phone listing out the steps.

  1. Installed Rosbridge

  2. Installed apache2 Web Server

  3. Enable SSL module

  4. Configured apache2 for HTTPS, used the command
    sudo make-ssl-cert generate-default-snakeoil --force-overwrite sudo a2ensite default-ssl

  5. Restart the apache2 server

  6. We are using the speechcommands.html present in /scripts and /fronts folders in /var/www/html/

  7. We modified the speechcommands.html as speedcommands_sat.html and add some http post calls around line 1230

  8. To allow ssl communication between browser and the robot
    copied snakoil.key to /etc/ssl/certs/ and make it readable

  9. Added the certificate and key in rosbridge_websocket.launch

  10. Install ft2_web_publisher

  11. we start the robot , kill roslaunch and roscore
    start the rosbridge freshly with the modified file to take the ssl as true and certs location

  12. relaunch as show below
    roslaunch rosbridge_server rosbridge_websocket.launch

  13. Entered WSS::9090 in speechcommands.html

  14. Press the button connect

  15. After some time the page says “done unable to connect”
    We also tried to check the websocket logs from the server side using ptrace but with no luck

The robot ships with rosbridge already running by default, ws on port 9090 and wss on port 9443.

It loads the ssl keys from /etc/ssl/certs/ssl-cert-snakeoil.pem and /etc/ssl/private/ssl-cert-snakeoil.key


Hi @davecrawley @rohbotics
With the default rosbridge running we were unable to get the https and wss working .Initially we tried with default rosbridge itself