Cannot SSH into pi image

I’ve been trying to ssh into the my pi from my laptop, and they’re connected via ethernet. When i try

ssh ubuntu@ubiquityrobot.local I get -
ssh : Could not resolve hostname ubiquityrobot.local: Name or service not known

ssh ubuntu@ and put int the password, I get -
Permission denied, please try again.
Permission denied (publickey,password).

I’ve even tried using putty and downloading different versions of the image but nothing is working.

Hi @osowande,

You said you are connected to the Pi via ethernet directly via Ethernet? This won’t work the way you are expecting, by default the Pi will expect a DHCP server to be available on Ethernet.

Can you connect to the ubiquityrobotXXXX wifi network that the Pi brings up? You should be able to SSH via wifi once you are connected to that network.


At some point I was connected with both, but I still got the error.

Just to confirm, you are using ubuntu as the password right? The SSH login is ubuntu as both the username and the password.

Thank you so much! It works now,but I had to disconnect the ethernet though. Is there a way I can still use it?

If you want to use the Ethernet port directly with your laptop, you will have to either have a DHCP server on your laptop, or configure one on the Pi.

Alternatively you can set something up with static IP addresses on both the Pi and the Laptop.

You could also connect both devices to an existing ethernet network with a DHCP server.


Okay, thank you very much for all the help

Are you using a Pi4 on am MCB board that is prior to rev 5.2? Thank you