Can not run rostopic battery state

I tried running rosrun teleop_twist_keyboard command to move magni but it says “Waiting for subscriber to connect to /cmd_vel”. And then, I saw someone had the same problem as me and the comment said to check the battery state, so I tried rostopic echo /battery_state to see my battery status but nothing show up. Can anybody please help me ?

Hmm, are you running the commands through SSH on the robot, or is the robot connected to the workstation and you’re running nodes remotely on that?

If through SSH, then the motor node is likely either not running (check rosnode list | grep motor) or not establishing serial with the MCB (check rostopic echo /diagnostics_agg if there’s Firmware not reporting its version being printed a lot). If you get the first one you can try rosnode kill -a and then roslaunch magni_bringup base.launch to restart it (and you should be able to see any errors on screen when it runs), the second one might require a firmware update.

If you’re running on the workstation then it may be a networking issue, since ROS often connects in this odd way where topics and nodes are listed but no data is sent to topics. Usually sorting out /etc/hosts on the workstation solves that.

Please write an email to and in the subject say perhaps ‘Cannot control my Magni using teleop_twist’. State in the email to have this issue brought to the attention of mark Johnston (me) please.