5V Main supply seems to be inactive


I have a Magni which I had not used for a while. Recently I tried to run it with my Raspberry Pi 4, running the Ubiquity Robotics Magni image and the board was unable to power the Raspberry Pi. Upon checking, I found out that the 5V Main supply LED was off while the rest of the three LEDs (12V Aux, 12VMain and 5V Aux) were on. The status LED was also off. The board I have is rev 5.3 and I have attached a picture as it looks when both the main switch and the motor switch are turned on.

I am not sure why this is happening. Would really appreciate any help on this.

Thank you.

If you have a sonar board then turn everything off and unplug the 50 pin cable to the sonar board. This will help isolate the problem in case it is related to sonar board.

Also, do you use the extra power jacks and in particular the one that is white and says ‘MAIN’ which has 5V and 12V on it.

Are you able to check the connector for the Raspberry Pi very carefully and see if it got inserted off by one pin or something?

Finally, turn off all power, remove the Raspberry Pi 4 from the unit because it also uses the 5V. See if you can power on the Magni and if the 5V is active at that point with no Pi plugged in.


Hi Mark,

We’re having a similar issue with our board as well. The 5V/12V source (white 4pin connector) to the left is working fine (confirmed with voltage meter), but the 5V/12V next to it on the right only has the 12V working (0V reading off of both the 5V pins).

It tried what you suggested above, by removing the Pi and the Sonar boards, and have the same results.


For both of you, please send an email to support@ubiquityrobotics.com

In the subject line please state this: To Mark MCB replacement.

BOTH: If your board has a white serial number tag please tell me the first 4 characters of the number, better yet if full number. Some boards were missing the tag.

BOTH: Please tell me the country you reside in as this helps me plan how to get a board to you.

Do not modify the board in any way as I need to determine what failed.

KRIS: Please confirm board revision which is on white large letter silkscreen as seen in the first picture on this thread. I would like to know if your cpu was the Pi4 as well as this may be key to this sort of failure.

Sorry for the trouble this has caused. At this time I am expecting the latest run of rev 5.3 boards in combination with use of the Pi4 is involved.

Stay Healthy,