5G wifi problem

Hi guys,

I am using a raspberry pi 4 and the latest image. I don’t know exactly how I mess it up with the network setting until I found out that I couldn’t discover 5G wifi.
I did remove the pifi, however, even if I install it back, I still couldn’t see any 5G network.
Is there any way to figure out the problem and restore it?
Thank you for your kind help.


I just flashed a brand new latest image, however, it seems that the deflaut setup doesn’t enable me to see 5G network either.

Not sure this helps or not. The ethernet cable also doesn’t work.
Are they realted or not?

If I do: dmesg | grep brcmfmac

There is a error :rtc-ds1307: probe of 1-006f failed with error -121.
And the Firmware is BCM4345/6 wl0: Feb 27 2018 version 7.45.154.

Surprsingly, if I put the same SD into a 3B+ , the 5G wifi worked.
I have tested the image on two different raspberry pi 4, so probably it is not the raspberry pi 4 problem.
I have the 4G version.

Hi all,
I figured it out the reason why I can’t get 5G hz wifi. You might want to set your country before you can use 5G hz. Here is what I did.
sudo apt install iw
iw reg set [your country code]
Then you wait for 30 seconds, you should be able to see 5G wifi SSID.
Country code: I am in Australia, so it is AU.

The problem is once you reboot, it is gone. I haven’t figured out how to make it permanent.
Any advice would appreciated.

Hi @alanypf,

I believe you can set the REGDOMAIN for wifi to your country code in /etc/default/crda.

For Australia you would want to do REGDOMAIN=AU, that should make the country setting presistent across reboots.


It works with this method.
Thank you, sir.
Another way is to generate a script to run every single time I reboot.
But I think this way is much better.