Not able to update software - not enough space in boot

I downloaded and installed the image (Ubuntu with ROS kinetic) from your website for Raspberry Pi b+. However the softwares cannot be updated since it says not enough space on the boot drive. I looked over the internet to solve this issue and also tried some but still its showing the same error. Can someone help please?

What is the output of df -h?

Whzt sized SD card are your running on?

I am using 16 GB card.
Output of df -h:
ubuntu@ubiquityrobot:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 15G 4.1G 11G 29% /
devtmpfs 434M 0 434M 0% /dev
tmpfs 438M 32M 407M 8% /dev/shm
tmpfs 438M 12M 426M 3% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 438M 0 438M 0% /sys/fs/cgroup
/dev/mmcblk0p1 63M 22M 41M 35% /boot
tmpfs 88M 20K 88M 1% /run/user/1000

I have used sudo apt autoremove and also downloaded the bleachbit tool to clean up space but still it is showing the error -

I went back and checked as i remotely do my updates via ssh.
It would seem the update tool from the desktop on the rpi gives this error. I tested this on a 64GB and 128GB card and got the exact same error, odd the same on all sd cards? Was this something turned off intentionally and is now, lets say a feature?

I am not sure why the desktop utility is acting up in this way. Everything works fine with sudo apt update; sudo apt upgrade on the command line.

Also the boot partition will be the same size no matter what SD card you are on.