RPI 4 - of course it's not working


Silly of me I tried the rpi tutorial on a RPI4,

why would it work, right ? it’s linux after all, story of my life

on a more serious note, is there a ready made image for RPI4 ? or some way to fix this ?

tutorial : http://wiki.ros.org/ROSberryPi/Installing%20ROS%20Kinetic%20on%20the%20Raspberry%20Pi

error :

/home/pi/ros_catkin_ws/src/rospack/include/rospack/rospack.h:108:10: fatal error: boost/tr1/unordered_set.hpp: No such file or directory


Hi @phil123456,

Sorry for the poor experience. Ubiquity Robotics doesn’t maintain that page, we do have our own Raspberry Pi Image, with support for the Pi 4 in progress.

Not everything is working yet, but you can see the current status here ROS image on Raspberry Pi 4?.

I can at least report that the RPi4 image seems stable and usable, so Kinetic will run on the RPi4. I’ve also loaded Melodic on a 4, with good success, but haven’t yet tried to add a significant number of ROS packages.

1 Like

thanks I’ll have a look